Is tailscale available for OpenWRT 19.07?

No, tailscale can’t be installed using¬†opkg on OpenWRT 19.xx. I have experimentally verified this using a MIPSBE router with OpenWRT 19.07.10.

However, tailscale is available on OpenWRT starting from version 21.02 - source: tailscale package page on OpenWRT.